[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Mail4ME: Help


Lew,

the J2ME specs don't say much about the protocols that have to be supported
by a compliant device. A device vendor can decide which ones he/she wants to
or is able to support. The only thing that's required by the specs is HTTP.
Unfortunately that doesn't suffice for POP3 and SMTP - these two need plain
TCP/IP sockets to work.

According to some other source in the web (javamobiles.com), the i85s should
support plain sockets, though, so the problem must be somewhere else.

I think I'll move to plan b: I'll send you a version that is a bit more
verbose about the connection process. Can take me a few hours, though,
because I'm currently at work (at least I *should* be working <g>), so I'll
have to do this at home.

Jörg

----- Original Message -----
From: "Lew" <lew@futureroads.com>
To: <mail4me@enhydra.org>
Sent: Thursday, October 18, 2001 12:14 PM
Subject: Re: Mail4ME: Help


Jorg,

I am the CTO of Futureroads and not a programmer/developer. Sorry if I don't
know these answers. But I don't know about "plain socket support". But we
are using other network aware apps that pull data from web sites, etc.

Lew


At 12:57 PM 10/18/2001 +0100, you wrote:
>Lew,
>
>does the i85s provide plain socket support?
>
>Jörg
>
>----- Original Message -----
>From: "Lew" <lew@futureroads.com>
>To: <mail4me@enhydra.org>
>Sent: Thursday, October 18, 2001 11:56 AM
>Subject: Re: Mail4ME: Help
>
>
>Jorg,
>
>Sorry the i85s has no means that I'm aware of to see these things.
>
>Lew
>
>
>At 12:45 PM 10/18/2001 +0100, you wrote:
>>Hi Lew,
>>
>>does the i85s have a means to watch the MIDlet's output sent to
>>"System.out"? If so, you might enable the "debug" switch and have a look
at
>>the protocol information for POP/SMTP in both directions. Maybe that
helps.
>>If you see *no* protocol information at all, then the connection object
>>can't be created. I see three possibilities why this might be the case,
but
>>can't validate any of them due to lack of a i85s:
>>
>>(1) Loading classes by name doesn't work at all. Shouldn't be the case
>since
>>this would make the whole Generic Connection Framework useless.
>>
>>(2) Loading of the specific "ConnectionImpl" class used in Mail4ME doesn't
>>work for some reason. Anybody has an idea?
>>
>>(3) The "microedition.platform" property isn't defined on the i85s,
>although
>>it should be according to the J2ME specs.
>>
>>The latter seems the most likely possibility to me. I'll see that I
provide
>>you with a JAR file that displays more info about the ConnectionImpl
>loading
>>process later today. Maybe this helps.
>>
>>Regards
>>
>>Jörg
>>
>>----- Original Message -----
>>From: "Lew" <lew@futureroads.com>
>>To: <mail4me@enhydra.org>
>>Sent: Thursday, October 18, 2001 11:05 AM
>>Subject: Re: Mail4ME: Help
>>
>>
>>Don't know about anything special about Mindspring's setup. I have used
>them
>>for other wireless e-mail like via the Handspring Visor and Visor Phone,
>>etc. The error occurs as soon as I press "OK" fater entering all the setup
>>info.
>>
>>Thanks,
>>Lew
>>
>>
>>At 11:53 AM 10/18/2001 +0100, you wrote:
>>>Hello Lew,
>>>
>>>is there anything special about the POP3/SMTP services at mindspring? For
>>>example, do they run on a non-standard port number? Also, when exactly
>does
>>>the problem occur? When you press "ok" in the "setup" dialog?
>>>
>>>Regards
>>>
>>>Jörg
>>>
>>>----- Original Message -----
>>>From: "Lew" <lew@futureroads.com>
>>>To: <mail4me@enhydra.org>
>>>Sent: Thursday, October 18, 2001 10:30 AM
>>>Subject: Mail4ME: Help
>>>
>>>
>>>> >Date: Sun, 14 Oct 2001 07:15:30 -0400
>>>> >To: enhydra@enhydra.org
>>>> >From: Lew <lew@futureroads.com>
>>>> >Subject: Mail4Me error
>>>> >
>>>> >I just tried to execute Mail4Me on my i85s for the first time and got
>>the
>>>following error...
>>>> >
>>>> >JavaLangNullPointerException null
>>>> >
>>>> >The only thing I had a question about that might be wrong in the setup
>>is
>>>the field "hostname.hostisp.com". My host is Mindspring. I tried
>>>mindspring.mindspring.com and just mindspring.com ... both gave me the
>same
>>>error.
>>>> >
>>>> >Thanks,
>>>> >Lew
>>>> >
>>>> >
>>>> _______________________________________________
>>>> Mail4ME mailing list
>>>> Mail4ME@enhydra.org
>>>> http://support.enhydra.org/mailman/listinfo.cgi/mail4me
>>>>
>>>
>>>_______________________________________________
>>>Mail4ME mailing list
>>>Mail4ME@enhydra.org
>>>http://support.enhydra.org/mailman/listinfo.cgi/mail4me
>>>
>>_______________________________________________
>>Mail4ME mailing list
>>Mail4ME@enhydra.org
>>http://support.enhydra.org/mailman/listinfo.cgi/mail4me
>>
>>_______________________________________________
>>Mail4ME mailing list
>>Mail4ME@enhydra.org
>>http://support.enhydra.org/mailman/listinfo.cgi/mail4me
>>
>_______________________________________________
>Mail4ME mailing list
>Mail4ME@enhydra.org
>http://support.enhydra.org/mailman/listinfo.cgi/mail4me
>
>_______________________________________________
>Mail4ME mailing list
>Mail4ME@enhydra.org
>http://support.enhydra.org/mailman/listinfo.cgi/mail4me
>
_______________________________________________
Mail4ME mailing list
Mail4ME@enhydra.org
http://support.enhydra.org/mailman/listinfo.cgi/mail4me